224: Android用のコンパイルできません


最新状況

タイトル Android用のコンパイルできません
状態 完了
カテゴリ その他
作成日時 2012-01-03 05:02:13
最終更新日時 2012-08-27 06:04:53

履歴

1 | 2012-01-03 05:02:13 | 提案
gekitora at gmail.com
初めて書かせていただきます。
バグ報告ではないので不適切かもしれませんが、他に質問ができるところがあるかわから
ず、こちらに書かせていただきます。
ONScripter on Androidのページを参考に、Android用のコンパイルをしようとしたのです
が、
最後の
> ../apache-ant-1.8.2/bin/ant -lib src debug
を実行すると、以下のようなエラーで止まります。

BUILD FAILED
C:\Program Files\Android\android-sdk\tools\ant\build.xml:602: The following 
error occurred while executing this line:
C:\Program Files\Android\android-sdk\tools\ant\build.xml:622: Compile failed; 
see the compiler error output for details.

当初Windows7の64bitで作業していましたが、環境を変えて試してみようとVistaの32bitで
やってみても同じ結果になりました。
検索しても解決方法など見つからず、こちらで相談させてもらえないかと書き込むしだい
です。

2 | 2012-01-06 12:30:20 | 修正済
ogapee at aqua.dti2.ne.jp
ご報告ありがとうございます。

おそらく最新の android-sdk-r16 をお使いだと思います。
これを使ってコンパイルしたところ、検索パス上に置いた junit-4.*.jar がなぜか見つか
らず、たしかに報告していただいた不具合が生じるようです。

それ以前の、例えば android-sdk-r15 では正常にコンパイルできることを確認しておりま
す。

http://dl.google.com/android/installer_r15-windows.exe
からダウンロード出来るようですので、こちらを試していただけないでしょうか。

3 | 2012-02-04 09:21:01 | 修正済
ogapee at aqua.dti2.ne.jp
junit-4.*.jar を使わないように SDK (onscripter_android.tar.gz) を修正しました。

現時点では android-sdk-r16 を使っても正常にコンパイルできるはずです。

4 | 2012-08-27 06:04:53 | 完了
ogapee at aqua.dti2.ne.jp
前回のやり取りから半年以上経過していますが、本報告は既に解決済みだと思われるた
め、完了とさせていただきます。

[リプライをつける]
Bug Tracking System 影舞 0.8.8
Powered by Ruby 1.8.7